summaryrefslogtreecommitdiffstats
path: root/plugins/pylon/CMakeLists.txt
diff options
context:
space:
mode:
authorMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2015-08-06 17:22:41 +0200
committerMatthias Vogelgesang <matthias.vogelgesang@gmail.com>2015-08-06 17:22:41 +0200
commitafd2b0abfa78027e4dbb195f88e90b01cd01feb4 (patch)
tree61d9ea2b56590a884b063a363e2d907ffe9ac3b2 /plugins/pylon/CMakeLists.txt
parentf1cb055bdd2cd18ecd09c1f7504c825eb884aaf0 (diff)
parent89ced9478f200facde423423df8c1718752f8a6c (diff)
downloadlibuca-afd2b0abfa78027e4dbb195f88e90b01cd01feb4.tar.gz
libuca-afd2b0abfa78027e4dbb195f88e90b01cd01feb4.tar.bz2
libuca-afd2b0abfa78027e4dbb195f88e90b01cd01feb4.tar.xz
libuca-afd2b0abfa78027e4dbb195f88e90b01cd01feb4.zip
Merge pull request #73 from miq/remove-anka-plugins
Remove ANKA plugins and change versioning scheme for bundled plugins
Diffstat (limited to 'plugins/pylon/CMakeLists.txt')
-rw-r--r--plugins/pylon/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/plugins/pylon/CMakeLists.txt b/plugins/pylon/CMakeLists.txt
deleted file mode 100644
index e2ace6b..0000000
--- a/plugins/pylon/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-cmake_minimum_required(VERSION 2.6)
-project(ucapylon C)
-set(VERSION "1.4.0")
-
-find_package(Pylon)
-
-if (PYLON_FOUND)
- set(UCA_CAMERA_NAME "pylon")
- set(PLUGIN_REVISION "1")
- set(PLUGIN_VERSION ${VERSION})
- set(PLUGIN_SUMMARY "Pylon plugin for libuca")
- set(PLUGIN_CHANGELOG "${CMAKE_CURRENT_SOURCE_DIR}/changelog.txt")
- set(PLUGIN_DESCRIPTION "Plugin for the Basler GigE CCD Camera.")
- set(PLUGIN_REQUIRES "libuca >= 2.0.0, libpyloncam >= 0.5.0")
- set(PLUGIN_VENDOR "ANKA Computing Group")
-
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/../package-plugin.sh.in
- ${CMAKE_CURRENT_BINARY_DIR}/../../package-plugin-${UCA_CAMERA_NAME}.sh)
-
- include_directories(${LIBPYLONCAM_INCLUDEDIR}
- ${CMAKE_CURRENT_SOURCE_DIR}
- ${CMAKE_CURRENT_BINARY_DIR}
- ${UCA_CONFIGDIR})
-
- create_enums(uca-pylon-enums
- ${CMAKE_CURRENT_SOURCE_DIR}/../../src/uca-enums
- uca-pylon-camera.h)
-
- add_library(ucapylon SHARED
- uca-pylon-camera.c
- uca-pylon-enums.c)
-
- target_link_libraries(ucapylon ${UCA_DEPS} ${LIBPYLONCAM_LIBRARIES})
-
- install(TARGETS ucapylon
- LIBRARY DESTINATION ${UCA_PLUGINDIR}
- COMPONENT ${UCA_CAMERA_NAME})
-endif()