summaryrefslogtreecommitdiffstats
path: root/engines/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'engines/Makefile.am')
-rw-r--r--engines/Makefile.am22
1 files changed, 15 insertions, 7 deletions
diff --git a/engines/Makefile.am b/engines/Makefile.am
index 2b7bb26..93e490a 100644
--- a/engines/Makefile.am
+++ b/engines/Makefile.am
@@ -1,14 +1,22 @@
-lib_LTLIBRARIES = libwestern.la
+lib_LTLIBRARIES = western_engine.la
libdir = $(pkgdatadir)/engines
if HAVE_RCD
-lib_LTLIBRARIES += librcd.la
-librcd_la_SOURCES = librcd.c
-librcd_la_LDFLAGS = -module -avoid-version -export-symbols-regex "rccGetInfo"
+lib_LTLIBRARIES += librcd_engine.la
+librcd_engine_la_SOURCES = librcd.c
+librcd_engine_la_LDFLAGS = -module -avoid-version -export-symbols-regex "rccGetInfo"
+librcd_engine_la_LIBADD = @RCD_LIBS@
endif
-libwestern_la_SOURCES = western.c
-libwestern_la_LDFLAGS = -module -avoid-version -export-symbols-regex "rccGetInfo"
+if HAVE_LIBGUESS
+lib_LTLIBRARIES += libguess_engine.la
+libguess_engine_la_SOURCES = libguess.c
+libguess_engine_la_LDFLAGS = -module -avoid-version -export-symbols-regex "rccGetInfo"
+libguess_engine_la_LIBADD = @LIBGUESS_LIBS@
+endif
+
+western_engine_la_SOURCES = western.c
+western_engine_la_LDFLAGS = -module -avoid-version -export-symbols-regex "rccGetInfo"
-AM_CPPFLAGS = -I../src @RCD_INCLUDES@
+AM_CPPFLAGS = -I../src @RCD_INCLUDES@ @LIBGUESS_INCLUDES@