summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@dside.dyndns.org>2012-11-09 21:01:23 +0100
committerSuren A. Chilingaryan <csa@dside.dyndns.org>2012-11-09 21:01:23 +0100
commit8c8d4f583a460904350b81cf38fed48fd5712cb2 (patch)
tree02ebced09ae047d193b35aa5e22b6aaa7ee1c2bd /configure.in
parent36c055ca75773ce36cc286afe00a1ceefc2449f6 (diff)
downloadlibrcc-8c8d4f583a460904350b81cf38fed48fd5712cb2.tar.gz
librcc-8c8d4f583a460904350b81cf38fed48fd5712cb2.tar.bz2
librcc-8c8d4f583a460904350b81cf38fed48fd5712cb2.tar.xz
librcc-8c8d4f583a460904350b81cf38fed48fd5712cb2.zip
Initial GTK3 support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 8817d6b..4baa8a3 100644
--- a/configure.in
+++ b/configure.in
@@ -136,6 +136,22 @@ else
fi
AM_CONDITIONAL(HAVE_GTK2, [ test $HAVE_GTK2 = yes ])
+
+dnl ***
+dnl *** GTK 3.0 (Optional)
+dnl ***
+AC_ARG_ENABLE(gtk3,
+ [ --disable-gtk3 disable gtk3 [default=enabled]],,
+ enable_gtk3="yes")
+
+if test "x$enable_gtk3" = "xyes"; then
+ PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.0.0, HAVE_GTK3=yes, HAVE_GTK3=no)
+else
+ HAVE_GTK3=no
+fi
+AM_CONDITIONAL(HAVE_GTK3, [ test $HAVE_GTK3 = yes ])
+
+
dnl ***
dnl *** Shared libraries support
dnl ***
@@ -407,6 +423,7 @@ echo ""
echo "User Interfaces:"
echo " GTK User Interface: $HAVE_GTK"
echo " GTK2 User Interface: $HAVE_GTK2"
+echo " GTK3 User Interface: $HAVE_GTK3"
echo ""
echo "Directories:"
echo " RCC Data Directory: ${rccdir}"