summaryrefslogtreecommitdiffstats
path: root/pcilib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pcilib/CMakeLists.txt')
-rw-r--r--pcilib/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/pcilib/CMakeLists.txt b/pcilib/CMakeLists.txt
index c9bf0fb..881b44c 100644
--- a/pcilib/CMakeLists.txt
+++ b/pcilib/CMakeLists.txt
@@ -1,11 +1,13 @@
include_directories(
${CMAKE_SOURCE_DIR}
+ ${PYTHON_INCLUDE_DIRS}
+ ${XMLLIB_INCLUDE_DIRS}
${CMAKE_SOURCE_DIR}/pcilib
)
-set(HEADERS pcilib.h pci.h export.h bar.h fifo.h model.h bank.h register.h kmem.h irq.h dma.h event.h plugin.h tools.h error.h debug.h env.h version.h config.h)
-add_library(pcilib SHARED pci.c export.c bar.c fifo.c model.c bank.c register.c kmem.c irq.c dma.c event.c plugin.c tools.c error.c debug.c env.c)
-target_link_libraries(pcilib dma protocols ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS})
+set(HEADERS pcilib.h pci.h export.h bar.h fifo.h model.h bank.h register.h kmem.h irq.h dma.h event.h plugin.h tools.h error.h debug.h env.h version.h config.h xml.h)
+add_library(pcilib SHARED pci.c export.c bar.c fifo.c model.c bank.c register.c kmem.c irq.c dma.c event.c plugin.c tools.c error.c debug.c env.c xml.c)
+target_link_libraries(pcilib dma protocols ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS} ${XMLLIB_LIBRARIES} ${PYTHON_LIBRARIES})
add_dependencies(pcilib dma protocols)
install(TARGETS pcilib
@@ -16,6 +18,6 @@ install(FILES pcilib.h
DESTINATION include
)
-install(FILES bar.h kmem.h bank.h register.h dma.h event.h model.h error.h debug.h env.h tools.h export.h version.h
+install(FILES bar.h kmem.h bank.h register.h dma.h event.h model.h error.h debug.h env.h tools.h export.h version.h xml.h
DESTINATION include/pcilib
)