summaryrefslogtreecommitdiffstats
path: root/pywrap/CMakeLists.txt
diff options
context:
space:
mode:
authorVasilii Chernov <vchernov@inr.ru>2016-02-26 10:19:58 +0100
committerVasilii Chernov <vchernov@inr.ru>2016-02-26 10:19:58 +0100
commite2550e6df11558ccd6e8b95f489c0988b34347af (patch)
tree7f959bbfe4a332b83e77f939a7c308d21e62b747 /pywrap/CMakeLists.txt
parent3bf5383a7ea03c5aa263aa4d8acf8b4949547319 (diff)
downloadpcitool-e2550e6df11558ccd6e8b95f489c0988b34347af.tar.gz
pcitool-e2550e6df11558ccd6e8b95f489c0988b34347af.tar.bz2
pcitool-e2550e6df11558ccd6e8b95f489c0988b34347af.tar.xz
pcitool-e2550e6df11558ccd6e8b95f489c0988b34347af.zip
1. pywrap:
- fix get_registers_list crash with bank != NULL - set correct python version in cmake install step 2. html_server: - merge set and get value boxes into one box - add registers bank view mode - read registers/properties values in bank/branch view mode 3. xml/test - remove cmosis registers - add multithread safe property example
Diffstat (limited to 'pywrap/CMakeLists.txt')
-rw-r--r--pywrap/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/pywrap/CMakeLists.txt b/pywrap/CMakeLists.txt
index f1c909e..f77c2ff 100644
--- a/pywrap/CMakeLists.txt
+++ b/pywrap/CMakeLists.txt
@@ -19,7 +19,7 @@ swig_add_module(pcipywrap python pcipywrap.i pcipywrap.c)
swig_link_libraries(pcipywrap ${PYTHON_LIBRARIES} pcilib)
#install pcilib python wrapper into Python site packages folder
-execute_process ( COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
+execute_process ( COMMAND python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()" OUTPUT_VARIABLE PYTHON_SITE_PACKAGES OUTPUT_STRIP_TRAILING_WHITESPACE)
install(TARGETS ${SWIG_MODULE_pcipywrap_REAL_NAME} DESTINATION ${PYTHON_SITE_PACKAGES})
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pcipywrap.py DESTINATION ${PYTHON_SITE_PACKAGES})