summaryrefslogtreecommitdiffstats
path: root/pcilib/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@suren.me>2015-05-08 20:06:36 +0200
committerSuren A. Chilingaryan <csa@suren.me>2015-05-08 20:06:36 +0200
commit79d9b2924d7b67ba08e022792adb92770f64e0c8 (patch)
treedc2ce5058978bfe88de1613291f21aa2ca7d9b0c /pcilib/CMakeLists.txt
parenta1889bc2f45b3d944652be6436569980f189922d (diff)
downloadpcitool-79d9b2924d7b67ba08e022792adb92770f64e0c8.tar.gz
pcitool-79d9b2924d7b67ba08e022792adb92770f64e0c8.tar.bz2
pcitool-79d9b2924d7b67ba08e022792adb92770f64e0c8.tar.xz
pcitool-79d9b2924d7b67ba08e022792adb92770f64e0c8.zip
Prevent excessive calling of getenv by debugging code for better performance
Diffstat (limited to 'pcilib/CMakeLists.txt')
-rw-r--r--pcilib/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/pcilib/CMakeLists.txt b/pcilib/CMakeLists.txt
index bb0abfd..c9bf0fb 100644
--- a/pcilib/CMakeLists.txt
+++ b/pcilib/CMakeLists.txt
@@ -3,8 +3,8 @@ include_directories(
${CMAKE_SOURCE_DIR}/pcilib
)
-set(HEADERS pcilib.h pci.h export.h bar.h fifo.h model.h bank.h register.h kmem.h irq.h dma.h event.h plugin.h tools.h error.h debug.h version.h config.h)
-add_library(pcilib SHARED pci.c export.c bar.c fifo.c model.c bank.c register.c kmem.c irq.c dma.c event.c plugin.c tools.c error.c debug.c)
+set(HEADERS pcilib.h pci.h export.h bar.h fifo.h model.h bank.h register.h kmem.h irq.h dma.h event.h plugin.h tools.h error.h debug.h env.h version.h config.h)
+add_library(pcilib SHARED pci.c export.c bar.c fifo.c model.c bank.c register.c kmem.c irq.c dma.c event.c plugin.c tools.c error.c debug.c env.c)
target_link_libraries(pcilib dma protocols ${CMAKE_THREAD_LIBS_INIT} ${UFODECODE_LIBRARIES} ${CMAKE_DL_LIBS})
add_dependencies(pcilib dma protocols)
@@ -16,6 +16,6 @@ install(FILES pcilib.h
DESTINATION include
)
-install(FILES bar.h kmem.h bank.h register.h dma.h event.h model.h error.h debug.h tools.h export.h version.h
+install(FILES bar.h kmem.h bank.h register.h dma.h event.h model.h error.h debug.h env.h tools.h export.h version.h
DESTINATION include/pcilib
)