summaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorVasilii Chernov <vchernov@inr.ru>2016-02-17 18:13:36 +0100
committerVasilii Chernov <vchernov@inr.ru>2016-02-17 18:13:36 +0100
commit52eb7f4fb76ddf99dedf44332aae7af4df76ab36 (patch)
tree607cd6617966ad9d9998ce0af87f1142de957a0c /apps/CMakeLists.txt
parent9a9ffd5594a5d27bbecf6160de2c33d44870f5bd (diff)
downloadpcitool-52eb7f4fb76ddf99dedf44332aae7af4df76ab36.tar.gz
pcitool-52eb7f4fb76ddf99dedf44332aae7af4df76ab36.tar.bz2
pcitool-52eb7f4fb76ddf99dedf44332aae7af4df76ab36.tar.xz
pcitool-52eb7f4fb76ddf99dedf44332aae7af4df76ab36.zip
Add test to repository. Add GIL states to pcilib_set_value_from_pyobject
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 4524db4..2a1471c 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -7,6 +7,10 @@ link_directories(
${CMAKE_BINARY_DIR}/pcilib
)
+find_package (Threads)
+add_executable(test_multithread test_multithread.c)
+target_link_libraries (test_multithread pcilib ${CMAKE_THREAD_LIBS_INIT})
+
add_executable(xilinx xilinx.c)
target_link_libraries(xilinx pcilib rt)