summaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorSuren A. Chilingaryan <csa@tir.suren.me>2024-04-04 01:08:26 +0200
committerSuren A. Chilingaryan <csa@tir.suren.me>2024-04-04 01:08:26 +0200
commitbe24c4d8751eaed09927596e9f0f218b03e2f1da (patch)
tree84ebcda1a4ae62f45a7e37c99d00fe6c25e33df8 /apps/CMakeLists.txt
parentd852b637800b0f91b9c921cda17311bc203939e5 (diff)
downloadpcidev-be24c4d8751eaed09927596e9f0f218b03e2f1da.tar.gz
pcidev-be24c4d8751eaed09927596e9f0f218b03e2f1da.tar.bz2
pcidev-be24c4d8751eaed09927596e9f0f218b03e2f1da.tar.xz
pcidev-be24c4d8751eaed09927596e9f0f218b03e2f1da.zip
Add sample apps to use event and dma engines
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 761bb2b..de45e38 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -8,6 +8,14 @@ link_directories(
${PCILIB_LIBRARY_DIRS}
)
+add_executable(stream-dma stream-dma.c)
+target_link_libraries(stream-dma ${PCILIB_LIBRARIES})
-add_executable(grab grab.c)
-target_link_libraries(grab ${PCILIB_LIBRARIES} ipecamera)
+add_executable(stream-events stream-events.c)
+target_link_libraries(stream-events ${PCILIB_LIBRARIES})
+
+add_executable(grab-frame grab-frame.c)
+target_link_libraries(grab-frame ${PCILIB_LIBRARIES})
+
+#add_executable(ipecam ipecam.c)
+#target_link_libraries(ipecam ${PCILIB_LIBRARIES} ipecamera)