summaryrefslogtreecommitdiffstats
path: root/build/linux/configure.ac
diff options
context:
space:
mode:
authorWillem Jan Palenstijn <Willem.Jan.Palenstijn@cwi.nl>2014-10-02 15:19:47 +0200
committerWillem Jan Palenstijn <Willem.Jan.Palenstijn@cwi.nl>2015-01-19 11:15:32 +0100
commit35fa8514fcd344615f19fb359471161b6bd58c73 (patch)
tree402a30eab2c7f1835c5e88457ef1dddf34752eca /build/linux/configure.ac
parent1341bd26aa9007c3fe91044425ae3a96e8b4854b (diff)
downloadastra-35fa8514fcd344615f19fb359471161b6bd58c73.tar.gz
astra-35fa8514fcd344615f19fb359471161b6bd58c73.tar.bz2
astra-35fa8514fcd344615f19fb359471161b6bd58c73.tar.xz
astra-35fa8514fcd344615f19fb359471161b6bd58c73.zip
Add --with-cuda-compute option to configure
Diffstat (limited to 'build/linux/configure.ac')
-rw-r--r--build/linux/configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/build/linux/configure.ac b/build/linux/configure.ac
index 4c9685b..11a8ff2 100644
--- a/build/linux/configure.ac
+++ b/build/linux/configure.ac
@@ -121,11 +121,15 @@ if test x"$HAVECUDA" = xyes; then
fi
AC_MSG_RESULT($HAVECUDA)
+AC_ARG_WITH(cuda_compute, [[ --with-cuda-compute=archs comma separated list of CUDA compute models (optional)]],,)
if test x"$HAVECUDA" = xyes; then
AC_MSG_CHECKING([for nvcc archs])
dnl 10 11 12 13 20 30 32 35 37 50
- ASTRA_FIND_NVCC_ARCHS([10 12 20 30 35 50],NVCCFLAGS,NVCCARCHS)
- AC_MSG_RESULT($NVCCARCHS)
+ if test x"$with_cuda_compute" = x; then
+ with_cuda_compute="10,12,20,30,35,50"
+ fi
+ ASTRA_FIND_NVCC_ARCHS([$with_cuda_compute],NVCCFLAGS,NVCCARCHS)
+ AC_MSG_RESULT([$NVCCARCHS])
fi