summaryrefslogtreecommitdiffstats
path: root/build/linux/configure.ac
diff options
context:
space:
mode:
authorWillem Jan Palenstijn <Willem.Jan.Palenstijn@cwi.nl>2015-03-09 18:12:37 +0100
committerWillem Jan Palenstijn <Willem.Jan.Palenstijn@cwi.nl>2015-03-09 18:12:37 +0100
commit30208e988315c8f576da6848cdc3236413c0cd10 (patch)
treeefdd9125e3c12c8ce000b4db3c812bce6ce8e296 /build/linux/configure.ac
parentc58a0f821cf494741e039d4b56aabb7a9ffe85bf (diff)
downloadastra-30208e988315c8f576da6848cdc3236413c0cd10.tar.gz
astra-30208e988315c8f576da6848cdc3236413c0cd10.tar.bz2
astra-30208e988315c8f576da6848cdc3236413c0cd10.tar.xz
astra-30208e988315c8f576da6848cdc3236413c0cd10.zip
Add check for required boost headers
Diffstat (limited to 'build/linux/configure.ac')
-rw-r--r--build/linux/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/build/linux/configure.ac b/build/linux/configure.ac
index 6558445..d9e1f1a 100644
--- a/build/linux/configure.ac
+++ b/build/linux/configure.ac
@@ -72,6 +72,17 @@ fi
AC_SUBST(HAVEBOOSTUTF)
AC_SUBST(LIBS_BOOSTUTF)
+BOOSTok=yes
+AC_CHECK_HEADER([boost/lexical_cast.hpp],[],[BOOSTok=no],[])
+AC_CHECK_HEADER([boost/any.hpp],[],[BOOSTok=no],[])
+dnl AC_CHECK_HEADER([boost/thread.hpp],[],[BOOSTok=no],[])
+dnl AC_CHECK_HEADER([boost/bind.hpp],[],[BOOSTok=no],[])
+AC_CHECK_HEADER([boost/static_assert.hpp],[],[BOOSTok=no],[])
+AC_CHECK_HEADER([boost/throw_exception.hpp],[],[BOOSTok=no],[])
+
+if test x$BOOSTok = xno; then
+ AC_MSG_ERROR([boost not found])
+fi
# nvcc, cuda