summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 15df761..6886a77 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -5,7 +5,15 @@ example_LDADD= ../src/librcc.la
if HAVE_GTK
bin_PROGRAMS+= rcc-gtk-config
rcc_gtk_config_SOURCES = rcc-gtk-config.c
-rcc_gtk_config_LDADD=../ui/librccgtk.la @GTK_LIBS@
+rcc_gtk_config_LDADD=../ui/librccgtk.la @GTK1_LIBS@
+rcc_gtk_config_CPPFLAGS = @GTK1_INCLUDES@ -I../src -I../ui
+endif
+
+if HAVE_GTK2
+bin_PROGRAMS+= rcc-gtk2-config
+rcc_gtk2_config_SOURCES = rcc-gtk-config.c
+rcc_gtk2_config_LDADD=../ui/librccgtk2.la @GTK2_LIBS@
+rcc_gtk2_config_CPPFLAGS = @GTK2_CFLAGS@ -I../src -I../ui
endif
EXTRA_DIST= input-russian.txt rcc.xml rcc-example.xml mpg123-rcc.patch
@@ -13,4 +21,4 @@ EXTRA_DIST= input-russian.txt rcc.xml rcc-example.xml mpg123-rcc.patch
test-russian: example
cat input-russian.txt | ./example
-INCLUDES = -I../src -I../ui @GTK_INCLUDES@
+AM_CPPFLAGS = -I../src -I../ui