| Age | Commit message (Collapse) | Author |
|
|
|
Update main.yaml for new directory structure
|
|
Change path to include 3.5 directory.
|
|
Without this change the azure deployment will fail because of the introduction of 3.5 and 3.6 directories.
#### Who would you like to review this?
cc: @gwestredhat @e-minguez
|
|
Without this change the azure deployment will fail because of the introduction of 3.5 and 3.6 directories.
|
|
|
|
We've set the verbose logging too eagerly and it ends up spewing a lot
of useless input in the "waiting for the pods to come up" phase.
|
|
This allows our users to keep the ansible.cfg file in the inventory as
well as putting e.g. LDAP certificates in.
Fixes #481
|
|
* Update openshift_release in the sample inventory
This removes setting the version for Openshift Origin, because the
only the latest release is actually available. So if a new Origin
release comes up, the installation will fail.
|
|
Add a contributing guide
|
|
|
|
Merge back 3.5 support
|
|
adding files for 3.6 update and optimizing some rhsm
|
|
|
|
|
|
|
|
|
|
|
|
* resolving #660 items
* only touch new node
|
|
|
|
|
|
|
|
|
|
need privilges to run non-atomic-command
|
|
|
|
|
|
Hoping that this will get our pull requests and code reviews more
consistent (and it should help people getting started with code
reviews).
|
|
|
|
|
|
|
|
|
|
|
|
Resync With Master
|
|
|
|
The end to end scripts just started failing because the contents of the
tarball shipping the oc tool changed.
Since the binary is always available on the master node after a
successful deployment, let us just copy it from there.
|
|
* README, all.yml, stack_params.yaml, openstack-stack: added docker volume size customisation
- app_volume_size changed to node_volume_size (it is node everywhere else)
* all.yml, stack_params.yaml,openstack-stack: added customisation for lb, etcd, dns
* README: updated
* README: updated info about ephemeral volumes
|
|
|
|
|
|
Mention of the role (which I don't find anywhere in the repo atm) breaks my refarch. I'd advise removing it all together.
|
|
* rolling back skip-packages
* guess can't use # lines
|
|
Adding OCP 3.6 files and modifications
|
|
|
|
|
|
|
|
|
|
|
|
Add end to end openstack testing to travis
|
|
|
|
* addition of glusterfs
* using existing instance groups
* allowing the ability to specify amount of app nodes
* better template due to ashcrow
* addition of 7.4 ami
* inclusion of brownfield
* teardown update
* linting
* higher required disk space
* require docker package before install now
* temporary variable location...will remove due to origin
* now can do pipelining at default
* testing priv escalation timeout fix
* transitioning to rhel_subscribe role
* roll back of use of rhel_subscribe
* addition of repos
* linting and missing reo
* rolling back
* use of overlay2
* need to code cloudformation for atomic but replace if required
* moving origin release to provider space
* installation params
* new add node steps
* linting
* rollback of rhel_subscribe
|
|
* Prep for 3.6 ocp/7.4 rhel spike
* Revert to 7.3
* Fix disk size on osdisk
* Fix size
* Add auto resize
* Fixup grow code to be cleaner and make sure docker is auto installed
* Make sure docker is started and enabled
* First pass move to 3.6 for HA Deployment
* Setup test
* Fix up installs
* Implement auto root device detection
* Move to new full auto growfs for root
* Prepare for upstream merge
* Implement new directory structure for multiple versions
* Add version support in allinone
* Fix template path on version
* Switch back to production
* Cleanup ansibledeployocp
* Re-add
|